Change the default value in the 'List' from EWS
Issue
Note: This article only applies to Discovery Attender 4.3
User is trying to create a list of users to search but is unable to use the selected Email Property for searching EWS data stores from the List generated in PowerShell.
Cause
The rewrite of EWS properties for DA 4.3 failed to deploy this option correctly.
Resolution
A change to a value in the registry should replace the default value for the List option in the Wizard.
Navigate to the Discovery Attender for Exchange key in the Registry under
DA 64-bit: HKLM\SOFTWARE\Wow6432Node\Sherpa Software Group\Discovery Attender for Exchange
DA 32-bit: HKLM\SOFTWARE\Sherpa Software Group\Discovery Attender for Exchange
Locate the string value called PowerShell Email Property and double click to edit the data field.
Change the Value data field to the integer value that matches your choice:
0 - UserPrincipalName
1 - PrimarySmtpAddress
2 - WindowsEmailAddress
Close the registry, try the List option again.