System.Exception: There was a problem getting people from the AD organizational unit...

Issue:

This error message may be encountered when performing a People search (also known as an Owner or Data Owners search).

System.Exception: There was a problem getting people from the AD organizational unit LDAP://domainname/OU=yourdomainusers,DC=xx,DC=local' : Unable to query active directory to retrieve a list of users: LDAP://domainname/OU=yourdomainusers,DC=xx,DC=local'
System.Runtime.InteropServices.COMException (0x8007203A): The server is not operational.

at System.DirectoryServices.DirectoryEntry.Bind(Boolean throwIfFail)
at System.DirectoryServices.DirectoryEntry.Bind()
at System.DirectoryServices.DirectoryEntry.get_AdsObject()
at System.DirectoryServices.DirectorySearcher.FindAll(Boolean findMoreThanOne)
at sherpaSoftware.ADQuery.Query.SearchAD(String szPath, String szFilter, String& szError, String[] szProps)
at sherpaSoftware.AoConnectorService.appSearchFolderThread.performPersonSearch_SearchActiveDirectoryOrganizationalUnit(IManagedPersonSearch search)

Cause:

This error message can be due to:

  • The Gimmal connector service configured in Windows Services has a password that is no longer valid, often due to administrative passwords being changed at the organization.

  • The domain controller is not accessible or active (less common).

Resolution:

For expired password:

  1. Stop any Gimmal services using the outdated password.

  2. Update the passwords for the services' accounts.

  3. Restart the updated services.

  4. Perform the People search again.