Skip to main content
Skip table of contents

There is an error in XML document (#, #)

Issue

When opening a project, a pop up appears with ‘There is an error in XML document (#, #)’. Any numbers can be listed, for example:

image-20241028-150930.png

or

image-20241028-151123.png

Cause

This error typically happens when there is corruption in the xml file found at the root of the project folder. This file is needed in the correct xml format to open a project.

Resolution

To resolve this issue, the XML file at the root of the project structure needs to be reconstructed to be in the correct format. The easiest method to do so is to copy a ‘healthy’ xml file from another project and modify the details to match the target project. Steps:

  1. Find a working project by trying to open other projects in Discovery Attender.

    1. Once found, make a note of the project location

    2. Close Discovery Attender.

  2. Navigate to the root of the working project folder found in Step 1and copy the [working project name].xml file found there.

  3. Navigate to the root of the project folder where you are seeing the issue.

  4. Rename the file called [issue projectproject].xml to [issue project name].xml.old found at the root of the issue project folder.

  5. Copy the [working project name]. xml file from Step 2 to the issue project folder. Rename this copied [working project name]. xml to the original name of the xml file which is not working. It should now be [issue project name].xml.

  6. Open the newly copied/renamed xml file and:

    1. Change the name (<project-name>) to the correct project name.

    2. Change the project unique identifier (<project-guid>) to the value found in the [issue project name].xml.old file, if present.

    3. Other tags can be changed to match the old data, but this is not required.

  7. Save the changes.

  8. Try opening the faulty project again in Discovery Attender.

If you have any questions on these instructions, or the resolution suggested above does not fix the issue, please contact support@gimmal.com.

JavaScript errors detected

Please note, these errors can depend on your browser setup.

If this problem persists, please contact our support.