User's OneDrive Documents Library does not appear in MAPIT
Note: This KB article includes instructions to change settings in Microsoft's M365 Admin Center and SharePoint Admin Center and is included here as a convenience. The information on this page is not guaranteed and is subject to change without notice. Please reference current Microsoft documentation for the must up to date and accurate information.
Issue
When you (the account you login with when clicking Sign In on the Profile Credentials tab) try to use MAPIT to migrate content into a user’s OneDrive Documents library, but the library is not shown on the Content tab for selection. You need to be able to select a document library as the target destination for migration to be successful.
Cause
By default, users' OneDrives are private and you will not be able to see the Documents library.
Resolution
There are two possible solutions, depending on the type of account you are using:
Your account is a Global Admin - Get Access to Files
Login to the M365 Admin Center as the Global Admin account.
Navigate to the Active Users and select the desired account.
Click OneDrive
Click Create link to files under Get access to files
Restart MAPIT and login as the Global Admin account
The user’s Documents library should now be visible on the Content tab for selection
Your account is not a Global Admin - Add account as site collection administrator
As a Global Admin (or other account with the correct permissions) login to the SharePoint Admin Center
Navigate to User profiles
Click Manage User Profiles
Search for the desired user in the Find profiles box
Click the drop down menu for the desired user user, next to their Account name
Click Manage site collection owners
Add the necessary account to the Site Collection Administrators and click OK
Restart MAPIT and login
The user’s Documents library should now be visible on the Content tab for selection